OFED 1.2 on OpenSuSE 10.2

Well, looks like it works. The relevant directory is http://downloads.scalableinformatics.com/downloads/OFED-1.2-rc2/OpenSuSE10.2/ and you need to install the kernel before you install the RPMs. Note that you will have to run mkinitrd by hand (very easy, just “mkinitrd”), and add it into /boot/grub/menu.lst . This is again, very easy to do.

Also, as I am a strong proponent of yum, this is a “yumable” path

[OFED-1.2-rc2-OpenSuSE10.2]
Name=OFED 1.2-rc2 for OpenSuSE 10.2
baseurl=http://downloads.scalableinformatics.com/downloads/OFED-1.2-rc2/OpenSuSE10.2/
enabled=1

which should let you do a

yum install ibtools

and other bits.

Viewed 7473 times by 1485 viewers

3 thoughts on “OFED 1.2 on OpenSuSE 10.2

  1. Hello,
    Is it possible to tell me what steps you took to get it working? I’m having the same issues you had trying to install OFED 1.2 on SUSE 10.2. I wanted to be able to build the rpms myself instead of grabbing them from your site.

  2. @jwong:

    I had to change build_env.sh to force 32 bit builds off. Do a search for a section of code which has build_32bit in it. There is an if-then construct. I placed a

    build_32bit=0

    right outside it, right before the return to caller.

    There are other issues that I am dealing with now. Turns out a change in the ABI has rendered an include file change so that the HZ macro is undefined. Go figure. Will try to resolve this and send a patch to whomever owns this code.

    Also working on getting a build going on Ubuntu 7.04

Comments are closed.